Stonefield Query has the following requirements:

  • It has to run on Windows Vista or later. Windows XP is not supported.

  • It requires the Microsoft .NET Framework version 4.5 or later. If that version isn't already installed on your system, it'll be downloaded and installed as part of the Stonefield Query Enterprise SDK installation (this may require a computer restart).

  • Stonefield Query Enterprise Web, the web front-end for Stonefield Query, requires a Windows server running Windows Internet Information Server (IIS). It must run as a full-trust application. Note that on a development system, you can run Stonefield Query Enterprise Web using Microsoft IIS Express, which the Stonefield Query Enterprise SDK installer automatically installs if it wasn't already installed.

  • Stonefield Query Enterprise Web works with any modern browser that supports HTML 5 and CSS 3. For Internet Explorer, version 10 or later is needed. We recommend using Google Chrome as our testing shows Stonefield Query is fastest in that browser.

  • For the web server, any server capable of running IIS 7.5 or later is fine. Running a report might take up 1-2 GB of memory for a short while. So we recommend 8 GB of RAM minimum plus 1 GB for every five concurrent users.