Can I install Stonefield Query Enterprise on a system that already has a copy of an earlier version of Stonefield Query?

Yes. The two versions of Stonefield Query are completely different and don't conflict with each other.

What version of the .NET framework is required?

Stonefield Query Enterprise uses version 4.5 of the .NET framework.